Nodes status at startup

Home Forums cherrytree Nodes status at startup

This topic contains 24 replies, has 4 voices, and was last updated by  Klaas Vaak 3 months, 4 weeks ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #124735

    Klaas Vaak
    Member

    I have the nodes status for the tree set at “Collapse all Nodes”. Despite that, when I start up CT, the nodes do not appear collapsed but are in the status when I closed CT.
    Please advise.

    #124736

    toxision
    Member

    Hi Klaas Vaak,
    are other settings applying to your changes?
    About your config file: did it wrote the configuration
    “rest_exp_coll = 2”

    If not, then maybe somethings wrong with saving settings or just this one in particular….

    Cheers,
    Chris

    #124737

    Klaas Vaak
    Member

    Het Toxision, thanks for replying.
    I have no problem with other settings responding correctly.
    As for the config file:

    The names I have found are these:
    fontconfig.def
    fontconfig.lib
    fontconfig.pc
    freetype-config
    gdkconfig.h
    glibconfig.h
    libfontconfig.dll.a
    libfontconfig-1.dll
    pkg-config.exe
    pkgconfig.lang

    I did not find “rest_exp_coll = 2” in any of them. So please tell me:
    * where is it?
    * what is the exact name of it?
    Many thanks.

    #124738

    toxision
    Member

    Hi Klaas Vaak,
    ok i haven’t exactly specified. It’s the config.cfg file and per default it is in: root:\Users\xxxxxx\AppData\Roaming\cherrytree
    Or in Cherrytree go to Help -> Open Preference Directory
    Check if the modification time matches when you made the setting change and take a look if you see the mentioned line “rest_exp_coll = 2”

    Cheers,
    Chris

    #124739

    Klaas Vaak
    Member

    Hi Chris, yes I found the config file, and in it I found the line “rest_exp_coll = 2”.
    But there is no date/time, this is what there is in that block in the config file:

    [tree]
    rest_exp_coll = 2
    nodes_bookm_exp = False
    nodes_icons = c
    aux_icon_hide = False
    default_icon_text = 25
    tree_right_side = False
    cherry_wrap_width = 200
    tree_click_focus_text = False
    tree_click_expand = False

    In fact, I don’t see a date in that whole config file.

    #124740

    toxision
    Member

    Hi Klaas,
    i was referring to the timestamp of the last modification of the file. Indeed in the file itself is no date specified. Nevertheless “rest_exp_coll = 2” is the correct entry and should trigger the “collapse all” function. In this case now i am lost, sorry :-/

    Chris

    #124741

    Klaas Vaak
    Member

    Can anybody suggest anything else?

    #124742

    Cosmo
    Member

    Open the second part of the tree settings. There is an option to expand the tree, if a node gets selected (the second last option on that page). Possibly it is activated for you. Disable this option.

    #124743

    Klaas Vaak
    Member

    Hi Cosmo. By “expand the tree, if a node gets selected” (Tree 2 in the preferences) I assume you mean the option “Expand node at mouse click”, the checkbox for which I have not checked. In fact, I have never had any of the checkboxes there checked. So that cannot be the cause.

    #124758

    Klaas Vaak
    Member

    Giuseppe, do you have any suggestions regarding this issue? The suggestions proffered by Tozision & Cosmo did not yield any positive result.

    #124759

    eureka
    Member

    If within Windows an AHK script might be created to
    launch CherryTree
    apply keys .. Shift + Ctrl + L
    (View > Collapse all nodes)

    #124760

    Klaas Vaak
    Member

    Hi Eureka, thanks for jumping in. An AKK script means 2 things:
    1. it is a workaround, which should not be necessary because CT has this feature
    2. the AHK script could only be launched after launching CT, which means carrying out an extra action. The action is small, I know, but it annoys me to know that the collapse feature is there natively but is just not working properly, for a reason no one knows.

    Am I seeing this the right way or am I missing something?

    #124761

    eureka
    Member

    Well I tried setting preferences to collapse nodes on startup and it does not work for me. Nodes startup open instead of collapsed.
    Version 0.38.4 in Ubuntu.

    #124762

    eureka
    Member

    P.S. correcting your impression there should only be one action to launch AHK script in one go since AHK will (a) launch CherryTree and then (b) execute keystrokes. Both actions in AHK script.

    I envisage a launcher on desktop or elsewhere for this.

    #124763

    Klaas Vaak
    Member

    OK, you are confirming that this feature on the Linux version of CT does not work either. I hope Giuseppe takes note because it needs to be fixed.

Viewing 15 posts - 1 through 15 (of 25 total)

You must be logged in to reply to this topic.