node expand, collapse colour

Home Forums cherrytree node expand, collapse colour

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  toxision 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #124962

    metallica
    Member

    Hi,

    I set custom colours in Cherrytree.

    rt_def_fg = #ffffff
    rt_def_bg = #232629
    tt_def_fg = #ffffff
    tt_def_bg = #232629

    So it is dark background with white text for tree pane.
    There is this sign > that expand, collapse nodes. I want to change its colour to white because with dark background it becomes invisible. Is it possible? I looked at config.cfg but I can’t find an entry for it.

    I can’t see such icon in
    /usr/share/cherrytree
    It is not an icon, correct?

    #124963

    toxision
    Member

    Hi metallica,
    which setting do you use for expand and collapse? Under “Tree 1” config are three different options: different cherries, selected icon or no icon at all….
    Best idea would be to use the “selected icon” setting and then pick a brighter one. Or you could even replace one of the graphics in /usr/share/cherrytree/bin
    (but in that case you might need to restore the graphic in case of Cherrytree updates)

    Cheers,
    Chris

    #124964

    metallica
    Member

    I am not talking about cherry icon, which I like and it is visible just fine but about the element that expand / collapse. When background is dark I don’t even see which cherry to click on because I don’t remember which cherry has subnodes.

    I am talking about the element that I marked red on this screenshot
    https://i.imgur.com/CnjTFRi.png

    On dark background this element is not visible, so I can’t see if this node has any subnodes.

    • This reply was modified 1 month ago by  metallica.
    #124966

    toxision
    Member

    Oh indeed…seems i mixed things up.
    And no, afaik there is no option to change these expand/collapse boxes. Think they are coming from the OS itself, because for me at work (Win 7) they look different then at home with Linux Mint.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.