.ctb write failed – writing to disk

Home Forums cherrytree .ctb write failed – writing to disk

This topic contains 20 replies, has 8 voices, and was last updated by  Sprinterdriver 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #122757

    kiweegie
    Member

    Hi Giuspen

    first would like to say I am very thankfull for finding Cherrytree. I’m an evernote refugee as I’m primarily a linux desktop user but need windows for work and need a note tool which is truly cross platform.

    One issue I’ve been having though I hope you or other forum members could help me with. I use Wuala to store files including my Cherrytree sqlite file so I can use it on both my Windows (8.1 pro 64-bit) desktop and my Laptop (Mint Cinnamon 64-bit)

    On occasion when saving the database I get error .ctb write failed – writing to disk

    I’ve tried saving to another location, e.g. my desktop and it still fails. I’ve seen posts where users were using USB stick to move the files around and you’d recommended moving to the XML file format, however my use of Cherrytree includes many images, tables etc and the manual recommends the sqlite format for this.

    Is this a known issue with a simple solution (he asks with fingers crossed). And is Wuala a supported method for sharing the Cherrytree file across multiple machines or are there preferred methods/apps?

    Thanks again, Kiweegie

    #122762

    giuspen
    Moderator

    Hi Kiweegie, what is the size of your database?

    #122797

    kiweegie
    Member

    Hey Giuspen, thanks for the reply and a Happy New Year to you!

    Has been behaving itself lately until this evening. Have been happily saving away as I’m transitioning all my notes out of Evernote and into Cherrytree.

    Current database size is 32.4MB though the error was happening when I first reported this and size was around the 20MB size mark.

    If there is a limit on database size then I could look to split into separate databases for each notebook rather than one big database perhaps.

    My notes are fairly image heavy but didn’t think 30MB was too big.

    It’s possibly an issue with Wuala as looking at the Wuala file where Cherrytree is stored there are several versions listed
    eg.

    Kiweegies_Notes.ctb~
    Kiweegies_Notes.ctb~~
    Kiweegies_Notes.ctb~~~
    Kiweegies_Notes.ctb-journal

    And then the “main” file

    Kiweegies_Notes.ctb

    The main file has an earlier modified time, most recent one is Kiweegies_Notes.ctb~

    I’ve tried saving file to another location with same name, or saving inside the Wuala directory with a new filename but both result in same error. The option with saving as new file name does create a new file however with a much smaller (3MB) file size.

    regards, Kiweegie.

    #122798

    kiweegie
    Member

    Just in case anyone else encounters similar issues I suspect its to do with how Wuala handles the .ctb files. I’ve opened a ticket with them as well and am currently trialling syncing with bittorrent sync for Cherry tree notes instead and will post back here in a week or so if things improve.

    Kiweegie.

    #122799

    kiweegie
    Member

    So far bittorrent sync has not exhibited the same issues with write failed and I’ve been adding a lot of notes over last couple days.

    Other sync tools may also work. Perhaps others can feed back here as to what they use/have used. And if successful or not.

    I think file syncing in combination with cherry tree itself is a pretty much essential requirement these days so a resource of recommended sync tools could be useful to newcomers to cherrytree like myself.

    Regards, Kiweegie

    #122800

    toxision
    Member

    Hello kiweegie,
    i am also syncing my CT database (*.ctb) but still via Dropbox. Not sure how Wuala works, as for Dropbox i just save the file in a folder which is under consideration for the Dropbox-Sync. My usage is a bit similar, as i have a LinuxMint (13 LTS) and Win7 laptop where i access my files, but never at the same time. Is that something you are doing, i mean having the database open on one, while accessing it from the other machine?

    Kind regards,
    Chris

    #122803

    kiweegie
    Member

    Hey Toxision

    good thought but no I close the cherrytree app each night at work, or have my laptop shutdown at home while at work so no overlap there.

    Wuala uses encryption so I’m thinking that may be causing the issue. I’ve had absolutely no problem since moving the cherrytree file to bittorrent sync and the database has increased to 47.3MB now

    Wuala support have acknowledged my ticket and I’m researching issue with them – will post findings (and hopefully solution) back here once i have something.

    regards Kiweegie.

    #122804

    eureka
    Member

    A suggestion. You could try opening a free (up to 1GB free) account with SpiderOak.

    SpiderOak (like Wuala) offers encrypted service so do keep a printed or written copy of your password off your PC as an insurance against a crash.

    Then rsync between CherryTree.db to SpiderOak created SpiderOak Hive local folder.

    I would use both the remote backup service and remote sync service.

    This will give you a benchmark to compare SpiderOak and Wuala.

    #122807

    kiweegie
    Member

    Hey Eureka (good name by the way 🙂 )

    I did actually try Spideroak before BtSync as it happens. However I was pronbably being extremely obtuse but I could not get my head around the spideroak UI. I did use it when I iniatally moved away from Dropbox around 2 years or so ago but found it a bit clunky and slow. Just my experience though.

    Since moving my cherrytree file into bittorrent sync and hammering away for a week I’ve had no issues.

    Wuala support have replied though so I’m back to testing that so we can find out why its failing there. Once I know more can post back,

    regards Kiweegie

    #122814

    drichard
    Member

    Hi all,

    I have the same problem and it is not in a context of synchronization : as kiweegie said it has worked nicely until a few days and now I can’t save my new data unless I add information on existing nodes
    Is there a limit in the nodes number or the size of the tree ?
    Regards

    #122831

    giuspen
    Moderator

    I would like to understand if the problem happens on both linux and windows or in windows only and if the data type is always .ctb

    What means “I can’t save my new data unless I add information on existing nodes”, what should you save if not new information?

    There should not be a fixed limit to the db, I know of users having much bigger databases but still I’m a bit concerned about huge databases.

    I think that the problem could be related to some particular data, if you remember what data you added after that you started to have the error that may help.

    Cheers.

    #122841

    drichard
    Member

    Hi Giuspen,

    Thanks for your answer

    – The problem is the same either for linux or windows

    – What I mean for “existing nodes” is the following :
    I store my information in a tree, adding new nodes for new topics or subtopics

    So, if I update an existing node either by adding new lines in the text page or update text, it’s OK, I can save my .ctdb file
    If I try to add a child node, then I have the message
    Waiting for your answer, I deleted somme nodes (4 or 5), then I could add child nodes. But afer a moment the error reappears again

    As for the type of data, I mainly store text, no image, sometimes tables … and many link between the nodes

    Cheers
    Daniel

    #122846

    giuspen
    Moderator

    Hi drichard, can you reproduce the problem running cherrytree in linux command line and see what it gets printed to the terminal pasting it here, also if you have error dialogs could you take a screenshot?

    #122848

    kiweegie
    Member

    Hi all

    I gave up on Wuala in the end and have been using BTSync exclusively to sync files between my work (Win8.1) desktop and home (Mint Cinnamon 64bit) laptop.

    Has been fine til today when I got this error again (on the windows box)

    C:\Users\<my_user>\Cherrytree\Kiweegie_notes.ctb write failed – writing to disk

    Cherrytree is NOT running on my laptop (ps -ef | grep cherrytree shows no processes)

    The .ctb~, .ctb~~ etc I believe are being generated by Cherrytree due to default setting in Edit > Preferences > Miscelleneous tab > Creaet a backup copy before saving (checked) > number (3)

    I don’t know about the .ctb-journal but given the file type I’d presume that is cherrytree driven too.

    However checking the log file generated on close pointed me to a conflict saying the file was open elsewhere and referenced Wuala….

    Log file path: C:\Program Files (x86)\CherryTree\bin\cherrytree.exe.log

    WindowsError: [Error 32] The process cannot access the file because it is being used by another process:

    Most odd as I had deleted from Wuala hadn’t I? Well I had, but Wuala has a trash system and the notes folder was still in there. The path referenced in the log file was pointing to the original Wuala location not the trash variant. But I emptied Wuala trash and can now save the file again.

    May be a complete red herring but hey you never know this might actually help someone. If nothing else the location of the log file might be useful.

    regards Kiweegie

    #122894

    hutou
    Member

    Hi,
    I too got a write error to disk after trying to insert an image (.png : “Notes.ctb write failed – writing to disk”
    Here is the terminal output when launching Cherrytree from the command line.

    sel node id=202, seq=12
    pending_edit_db_node_buff 202
    write node content, node_id 202 , write_dict {'upd': True, 'buff': True, 'hier': False, 'child': False, 'prop': False}
    Traceback (most recent call last):
      File "/usr/share/cherrytree/modules/core.py", line 1364, in file_save
        and self.file_write(os.path.join(self.file_dir, self.file_name), first_write=False):
      File "/usr/share/cherrytree/modules/core.py", line 1502, in file_write
        self.file_write_low_level(filepath, xml_string, first_write)
      File "/usr/share/cherrytree/modules/core.py", line 1412, in file_write_low_level
        else: self.ctdb_handler.pending_data_write(self.db)
      File "/usr/share/cherrytree/modules/ctdb.py", line 60, in pending_data_write
        self.write_db_node(db, tree_iter, level, node_sequence, node_father_id, write_dict)
      File "/usr/share/cherrytree/modules/ctdb.py", line 321, in write_db_node
        db.executemany('INSERT INTO image VALUES(?,?,?,?,?,?,?)', images_tuples)
    sqlite3.OperationalError: table image has 8 columns but 7 values were supplied
    

    Same problem after cleaning the Sqlite Database with the VACUUM command !

    Inserting the same image in a new database is ok !
    Regards

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.