Can't open encrypted ctz file

Home Forums cherrytree Can't open encrypted ctz file

This topic contains 22 replies, has 6 voices, and was last updated by  giuspen 2 months, 1 week ago.

Viewing 8 posts - 16 through 23 (of 23 total)
  • Author
    Posts
  • #123016

    giuspen
    Moderator

    strefo you can send me document and password in my private mail that you can find in cherrytree help–about dialog.
    in the directory(/ies) where you used to save the document you should find also files with the same name (i.e. pippo.ctx) plus trailing 1, 2 and 3 tildes (i.e. pippo.ctx~, pippo.ctx~~) you can try to remove the trailing tildes or just open them with 7zip and see if you can extract them…

    #123050

    matera
    Member

    By George, I think I’ve got it! Windows does seem to have been the problem. I uninstalled CT and re-installed it outside of the “Program Files” folder. Now I can open the file that didn’t work with the installed version.

    For some reason this doesn’t happen in every Windows machine, but when it does, it’s probably a good idea try an alternate install location. It appears to fix the “can’t write” problem too.

    I’ve had no trouble with it on two different computers at home, but when I’m at work I’ve had to open my personal encrypted file with a portable CT. Today, I tried switching the portable and installed files. The portable, in Program Files, gave the same “wrong password” message. Clue! 🙂

    #123053

    giuspen
    Moderator

    I’m having this same damn problem at my new computer at work, with windows 7.

    Actually I have the problem only if I run cherrytree double clicking on the password protected document, not if I run cherrytree from the windows menu and then open the document from cherrytree.

    I’ll try to find a solution to this, if only I could reproduce it at home, at work I have zero time to debug 🙁

    #124399

    vic
    Member

    I’ve been using the program for several years. But for the first time I encountered a problem I canт’t open the file with the password. The panel closes without action as if an incorrect password was entered.
    When I copy & paste the password from plain text editor everything works properly and the file opens.

    OS Fedora 24
    Cherrytree v.0.38.1; v.0.38.2

    #124407

    giuspen
    Moderator

    Hi vic, is this problem systematic now? Has this started when you upgraded cherrytree? If so from what version?

    #124414

    vic
    Member

    Hi,
    Additional info.
    I uses utf8 cyrillic chars in file names. And what I got from konsole (application closed after correct password input and <enter> ):

    $ cherrytree 2017-09-07_Сисадмин.ctx                
    
    7-Zip (a) [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
    p7zip Version 16.02 (locale=ru_RU.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz (206A7),ASM,AES-NI)
    
    Usage: 7za <command> [<switches>...] <archive_name> [<file_names>...]
           [<@listfiles...>]
    
    <Commands>
      a : Add files to archive
      ............
      x : eXtract files with full paths
    
    <Switches>
      -- : Stop switches parsing
      -ai[r[-|0]]{@listfile|!wildcard} : Include archives
      ..............
      -y : assume Yes on all queries
    Traceback (most recent call last):
      File "/usr/bin/cherrytree", line 78, in <module>
        f_main(args)
      File "/usr/bin/cherrytree", line 50, in f_main
        main.main(args)
      File "/usr/share/cherrytree/modules/main.py", line 235, in main
        CherryTreeHandler(args, lang_str)
      File "/usr/share/cherrytree/modules/main.py", line 74, in __init__
        self.window_open_new(args.filepath, args.node, True, True if args.filepath else False)
      File "/usr/share/cherrytree/modules/main.py", line 79, in window_open_new
        window = core.CherryTree(self.lang_str, filepath, node_name, self, is_startup, is_arg, False)
      File "/usr/share/cherrytree/modules/core.py", line 250, in __init__
        self.file_startup_load(open_with_file, node_name)
      File "/usr/share/cherrytree/modules/core.py", line 1494, in file_startup_load
        self.file_load(os.path.join(self.file_dir, self.file_name))
      File "/usr/share/cherrytree/modules/core.py", line 1977, in file_load
        self.db = self.file_get_cherrytree_data(filepath, True)
      File "/usr/share/cherrytree/modules/core.py", line 1908, in file_get_cherrytree_data
        esc_filepath)
    UnicodeDecodeError: 'utf8' codec can't decode byte 0xd0 in position 53: invalid continuation byte

    When I changed file name to latin chars only application became work properly.

    #124417

    giuspen
    Moderator

    Hi @vic, I added some cyrillic chars in the document name but it worked on my Ubuntu 16.04. What is your distro?

    #124418

    giuspen
    Moderator

    Oh sorry it was Fedora24 I read in the previous post… I’ll see if I can try on a Fedora

Viewing 8 posts - 16 through 23 (of 23 total)

You must be logged in to reply to this topic.