Automatic indentation of the paragraphs

Home Forums cherrytree Automatic indentation of the paragraphs

Tagged: 

This topic contains 6 replies, has 4 voices, and was last updated by  giuspen 1 week, 4 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #122510

    Hebbs
    Member

    Hello,

    I don’t remember if I have mentioned this before in a previous post, so I will point it out here: how do we remove the automatic indentation of each paragraph? The first line of the paragraph is currently the only one without indentation, and all the following lines are automatically indented by one or two characters.
    I understand that this feature may be appreciated by some users, and indeed it can be useful, but why make it default?

    Above all, can this feature be set as an option which can be disabled by the user?

    Thanks

    BTW, are you sure that the search functionality on the forum works properly? I have tried it with some common words and it does not return any hits at all. Could there be a bug?

    #122512

    Cosmo
    Member

    In preferences -> all nodes set the value for indentation to the value you wish, probably 0 will be the value you want. It works at once also for existing nodes.

    BTW: I like this feature. With this I can distinguish between “great” paragraph separation (where I set a empty line between 2 paragraphs) and a small paragraph separation (without the empty line in between). With indentation I can still easily see those paragraph breaks. This makes for me the readability especially in complicated subjects much better.

    #122515

    giuspen
    Moderator

    Hi, as Cosmo said you need to look at the preferences, tab “All Nodes”.
    In my understanding you probably search for the “Line Wrapping Indentation” parameter that you should move to 0.

    As for the bug in search, please provide an example since you are the first to report it. The best is if you can also refer to a CherryTree document (e.g. the manual).

    #124447

    hueyd
    Member

    Hello, I love this product. Currently running 0.38.2 on Mint 18.2

    How do I completely disable auto indentation? Perhaps this has to do with the bullet/numbered lists, but when I have a numbered list, pressing enter will increment the number and start the next item on the list. And if I press tab on a subitem, it will autoindent the parent, and sometimes change the bullet number/style on the parent.

    How do I completely disable both of these behaviours? I would like my indentation and numbering to be completely manual and not modifiable except through my own input. I have checked the options to disable auto indent, but this does not disable the above behaviours.

    Thank you very much

    • This reply was modified 3 weeks, 5 days ago by  hueyd. Reason: grammar
    • This reply was modified 3 weeks, 5 days ago by  hueyd. Reason: spelling & grammar
    #124453

    Cosmo
    Member

    What you describe is the idea behind those lists. Turn it off from the format menu, if you do not need it.

    #124463

    hueyd
    Member

    Thanks for the response, Cosmo.

    The format menus shows a list of options to remove formatting and set/unset bullet lists. Much of what I record in cherrytree are lists, but I don’t want the formatting to be automatic, and I don’t want to remove the formatting after the fact.

    How can I remove all autoformatting period so I can format as I edit for content? Something like, in vi:

    set noautoindent nosmartindent
    filetype indent off

    Thank you.

    #124475

    giuspen
    Moderator

    Hi hueyd, at the moment it is not possible to disable the lists management. I can have a look at that and add an option to disable this in the config.cfg (not a graphical interface for now since I’m not sure how many will find this useful). You will have to edit the config.cfg with a text editor. Are you willing to test a development version? If yes, for what operative system?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.